Back to overview
Downtime

Concept Logistics Backend API and Concept Logistics WebServices/Webhooks API are down

May 25 at 04:06am EDT
Affected services
Concept Logistics Backend API
Concept Logistics WebServices/Webhooks API

Resolved
May 25 at 04:10am EDT

Concept Logistics Backend API recovered.

Updated
May 25 at 04:09am EDT

Concept Logistics WebServices/Webhooks API recovered.

Created
May 25 at 04:06am EDT

Concept Logistics Backend API and Concept Logistics WebServices/Webhooks API went down.